Ask a question Report

Laptop sound on TV with HDMI cable [Solved/Closed]

Jen - Latest answer on Oct 25, 2012 02:33PM
Hi,
I have my laptop hooked up to my HDTV with an HDMI Cable. The picture is great but the sound only comes through my laptop. How do I make it come through my TV?
Thanks
Read more 
Answer
+1147
moins plus
I take it you are using your laptop to watch DVD etc on your HD TV. I had the same problem where the sound was coming out my laptop. I solved this by going in to the sound options on my computer (which you can access in your control panel) then set your sound default as HDMI. This should solve the problem, just remember to set the default back to the laptops speakers when you are finished using it on your TV.
I hope that helps.

shraz- Jun 21, 2010 04:55AM
if that doesnt work, if nothing works it has to be one thing
there is a hardware conflict/sharing, u need to check it out in your computer system information and you will probably have a 1rq22 hardware conflict
tdog- Jun 24, 2010 05:40PM
thanks worked great
sounder- Jun 28, 2010 10:11AM
If the sound does not work proberly right click on HDMI and select "Properties" That should open up the properties:) Then go to the 3rd tab and make sure the sound icon doesnt have a little "block" sign!
tayebeh- Jun 30, 2010 02:48AM
woooow, thank u so muchhhhh, very very easy solution
thank u thnak u thank yooooooooooooooooooooooooooou
dozy11 1Posts Thursday October 25, 2012Registration date October 25, 2012Last seen - Oct 25, 2012 02:33PM
thank you sounder, my monitor sounds better now :-)
Reply
Answer
+701
moins plus
Thankyou so, so, so much re: Vista solution. REALLY appreciate it.

Answer
+287
moins plus
you can get disabled playback devices such as hdmi or whatever else your computer has by opening the playback devices and right clicking in the space in the box and click 'show disabled devices.

Answer
+207
moins plus
ALSO!

After you go into "Manage Audio Devices" make sure you right click in that window,

then select "Display disabled devices"

That way the HDMI option will show up.

Then select HDMI, and click on "enable"

Close any audio output programs,

Then reopen and play them,

Wa-la! Sound from an HDMI cable. AWESOME!!

Answer
+72
moins plus
I dont know whether you guys have tried this but it works for me. Try :

control panel-device manager-system devices-high definition audio controller.

Enable it. In my case i have 2 high definition audio controller. Disabling one of it will disable the pc speaker & digital audio/spdif. Disabling the other will disable the ATI HDMI output with the tv icon. Enabling both will enable all sound playback device. You can actually open the sound playback device window and see the icon comes and goes as you play around enabling and disabling the audio controller.

Give it a try. Just sharing what works for me

Answer
+47
moins plus
I dont have the HDMI option in the sound .. I have two option
1. speakers and
2. SPDIF interface

then how can i enable the speaker of the TV through the laptop ?

Answer
+43
moins plus
OK for all you needs to know.

Connect the HDMI cable to the Laptop and the TV. Make sure the TV was OFF then Power it on so that the TV will then SEE the HDMI connection.

On the Laptop go to Start > Control Panel > Sounds > Right click on the "Digital Output Device" and set it as default. Depending on your Laptop will make the difference as to the name the HDMI device is under.

THIS IS the catch 22... some Laptop require you restart them after you save the changes, lol....

So while the HDMI cable is STILL plugged in and connected to the TV >>> restart <<< your PC.

Oh and something funny about Microsoft, sometimes you have to play sound in Windows Media CENTER before it will play sound through Windows Media Player.

If that fails... CALL YOUR LAPTOP MAKER, They have Tech Support for a reason

Answer
+21
moins plus
I followed these steps (setting the HDMI as the default) and now there is no sound period. It is not coming through the laptop or the tv. Any suggestions?

I find this most frustrating because the sound came through the tv the first 10 or so times I hooked the laptop up to it w/ the HDMI cable....

YouginB- Nov 2, 2009 09:16AM
Hi guys! Any news?

I've got the same problem. I'm trying to connect my Samsung r70 laptop (Windows 7 on board) with Philips 8404.

When I choose HDMI as a primary output audio channel the TV starts to play sound from ANALOG channel (tv tunner). I wasn't able to find on where to choose an audio source.
danny rkd993 - Dec 3, 2009 03:45AM
thank you so much!! it worked!!
ant1 rkd993 - Dec 28, 2009 12:11PM
Hi,

Just wanted to say, this at last allowed me to select HDMI Output as "default" in the sound menu of the "Control Panel" under Vista on my Toshiba laptop (wouldn't let me do that while the "Realtek HDMI" driver was enabled... and this is indicated everywhere as the first step to solution.
Sound still not playing via HDMI cable on my Pioneer amplifier but this has been the frst progress I managed in 2 days, thanksomuch !
Timm rkd993 - Jan 1, 2010 04:14PM
Worked!!! Thanks so much!
angelo rkd993 - Feb 19, 2010 12:52AM
Yes!
Thank you very much!
i have windows 7, I just update my driver, and Your driver is up to date. after this i go back and got ATI HDMI Output like default device.
If I have to go back to laptop speakers I just switch default.
Easy!

Thank you again
Answer
+14
moins plus
HDMI is a technology before its time during its time. It's had several modifications, including 1.0, 1.1, 2.1, 3.1 and so forth. While the video quality has always been 1080p, the audio has undergone several changes during the years.

It's possible that the HDMI port on your laptop isn't designed for audio at all. I would recommend looking for an optical, or try jacking your stereo up to the line out. Even if you were somehow successful getting the audio into your tv, HDTV audio is poor at best.

Extend a splitter cable from your headjack to the stereo with the red/white cables. it'll do you well, and most receivers can pro logic ii the audio to make it come through 5.1 quality (or comparable)

adzydt- May 30, 2010 09:00AM
I think this is the problem I have. But my laptop is brand new, literally bought last week, surely it should support HDMI audio?
When I go in to my sound settings on Windows 7 it says that the ATI HDMI Output is not plugged in and so I don't have the option to set it as a default device. So it seems like it should work but it is not recognising the cable?
I dunno.. If you could help that would be great.
Kale- Jun 27, 2010 02:20PM
exactly the same thing thats wrong with mine
Tyler- Oct 19, 2012 01:43AM
I just opened my volume control, then clicked on mixer. then on the left part of the mixer there was a scroll down box and I just kept changing the device until the sound came out of my tv.
I have a Dell inspiron laptop btw.
Answer
+12
moins plus
I solved my problem after 3 hours of screwing around. This arose after upgrading from Vista to 7.

Problem - hdmi wasn't showing up under devices for audio output. I reinstalled every driver individually that had to do with audio or video. Nothing worked.

Solution - I eventually downloaded the entire new chipset direct from intel and reinstalled the chipset and all hdmi/graphics drivers from that download. After restart it worked fine. Also needed to download newest itunes, but that worked too.

Hope I helped someone.

ps, i have a Sony VAIO FW-170J

Answer
+10
moins plus
Hey guys,
I just figured this out!

If you have sounds already playing on the laptop, then you must switch your default to the HDMI then go and re open the program ie itunes. Any other program playing sounds on ur laptop speakers will continue to play through the lap top speakers...

On VISTA do this
Right click your screen
go to personalize
on the left there is an option "connect to a projectror or external display"
Click the speaker picture, and set the default to HDMI by right clicking it and selecting make default.
Close your media programs, and then re-open them and hit play..

Presto! Sound will work!
This wasnt listed in my manual either i had to figure it out.
HOPE this helps, any questions email me.
Email Id removed for security

r13dod- Jun 18, 2010 08:28PM
i dont have the hdmi option on a mac
Prabhu- Jun 22, 2010 11:30AM
thanks.. really appreciate ur knowledge:)
raj- Jun 25, 2010 03:37PM
dude u r toooooooooooooo good, i would like to salute you,
jai- Jun 27, 2010 11:38AM
it won't let me set hdmi as default.. what do i do?
kylie- Jun 28, 2010 02:06PM
Thankyou so much, this worked straight away. I had been trying all day with the HDMI cable and a guy at the store told me it would never work without an extra audio cable,which I bought.....but even that didn't work. Now I only need the one hdmi cable, thanks again
Answer
+7
moins plus
Blue Ray movie, Hdtv trough hdmi laptop to external Lcd flat screen tv - no sound problem.
Solution:
1. Pause the movie
2. restart the computer
3. Hit play movie (in some cases, you'll have to turn off/on the tv)

Answer
+7
moins plus
I finally can figure it out how to get the sound to my LCD TV. All you have to do is changing your laptop screen resolution. Change it to the higest. First, it was @ 1280 x 720. When I changed to 1280 x 800, bummmp...sound went through. Good luck all.


TDLai

ssenator00- Nov 16, 2009 05:07PM
Hi, I contact sony support, and I finally got my problem SOLVED!,
INSTRUCTIONS:
1.- As it was told before, get the image only playing in the TV (NOT in the laptop display).
2.- Go to sound icon in the task bar (lower right) click right button, choose playback devices
3.- Mark DIGITAL OUTPUT DEVICE (HDMI) and click in the PROPERTIES BUTTON
4,- Choose SUPPORTED FORMATS tab
5.- UNCHECK: - DTS Audio
6.- UNCHECK: - Dolby Digital
7.- UNCHECK: - Microsoft WMA Pro Audio
This worked for me watching Blue Ray with InterVideo WinDVD BD for VAIO
Hope it works!,
Thanks,
Gus
j- Feb 19, 2010 05:36PM
Hey man it worked! I can not thank you enough. I have a HP, this should solve the problems for all computers. I reccomend all try this first!!
khop ssenator00 - Feb 26, 2010 10:04PM
This worked great!!! I have been driving myself crazy trying to figure out why I couldnt get sound I have a brand new hp and your solution worked perfectly!!! Thank you so much for your help!
Home User- Apr 26, 2010 08:28PM
This is the fix. Tech Support couldn't figure it out, but you did my friend. I have went through all of the above options with no luck at all. Thanks again! Avatar in Blu Ray is AWESOME!
yamstrummer- May 5, 2010 12:45PM
Absolutely wonderful. No geekspeak either. It still worked when i changed screen res. back again.
Answer
+5
moins plus
turn on hdmi input on tv. leave Tv on and shut down the computer plug in Hdmi cable to computer then restart the computer. the sound will work to the tv

Answer
+4
moins plus
I solved this by opening PowerDVD and from the menu going to :
Settings->audio settings->speaker environment. It was set on "2 speaker". I selected "HDMI" from the pull down list. Sound now came only from the TV. I'm paranoid so I don't turn the computer or the TV on until the HDMI cable is plugged in. Remember to put the setting back to "2 speaker" before you unplug the HDMI cable after watching. I couldn't open PowerDVD afterwards when I forgot this step.

Answer
+4
moins plus
HDMI is not the problem, right click on your mouse or pad, go on volume (it's between your time and volume) you have 3 option playback, recording and sounds. You need to go on Playback den disable speakers, enable HDMI output then enjoy :)
make sure you reverse the way things were (disable HDMI OUTPU AND ENABLE SPEAKERS) otherwise further problem in the future please try not to leave the way things are like for example remove the hdmi cable out of laptop.

Answer
+3
moins plus
After trying it many times with different laptops and different browsers and different LCD, I have figured out that at times you need to restart the browser before LCD would play sound from the browser after connecting with HDMI. I prefer to use Mozilla firefox as it has adblocks addon. And even when you take out HDMI, then again you need to restart your browser to resume the sound.
Hope it helps

Answer
+3
moins plus
Try manipulating the video player such DivX. You should be able to find a sound setting option (could be in preferences, options, tools, etc.) From here you can check the sound option on or off. Try a couple of times if it doesn't work the first time.

Answer
+2
moins plus
i had same problem.i have dell and a samsung.its a simple case of getting jack ,male on both ends ,the tv should have seprate female jack for pc section.

Hungry- Jun 6, 2009 05:37AM
I take it you used a non HDMI link. I don't have HDMI on the PC but do on the TV.

What link did you use??
Answer
+2
moins plus
I have the same problem I have Dell laptop and Philips Tv. before i had the Vista installed and worked nicely with the HDMI cable just switch to HDMI from the TV and life goes on with out problems, but since last week I updated from Vista to W7 every thing went bad when trying to watch a film from the TV it comes without sound and the sound comes out from the laptop only, I also noticed that if i switch back to the TV and go back to HDMI I also loose the picture from the TV, then I have to restart the laoptop to get the picture back. If any one have encountered this problem pls post thanks

Noevall

Chosen- Feb 7, 2010 07:42AM
Press and hold the Windows key and P and release. This will switch Video location, or since you have a Dell, press and hold the Fn (Function) Key and (in most cases it is..) F8 and that will also switch Video.
Mac- May 6, 2010 08:01PM
I have been watching movies from my laptop to my tv for months with my hdmi cord. Tonight I could not for the life of me get it to show on my tv. I configred, added a second display...all that crap. Was getting so mad because it would blink on my tv then disappear. I just read this, pressed fn F8 and voila, magic. All I can say is thank you. You saved my laptop from going through my tv.
1 2 Next
This document entitled « Laptop sound on TV with HDMI cable » from Kioskea (en.kioskea.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.