Ask a question Report

Files on external drive changed to shortcuts [Solved/Closed]

Hardy - Latest answer on Jan 9, 2013 06:28AM
Hello,
My external hard drive has some virus because of which all files are showing as short cuts.
Please guide me.
Read more 
Answer
+162
moins plus
Hello,

Try this 1.

Check whether the files are not in hidden mode. Follow the following steps.

Step 1:

Click on the below link and download the file "AutorunExterminator"

http://en.kioskea.net/download/download-11613-autorun-exterminator

Extract it --> Double-click on "AutorunExterminator" --> Plug your External

hard drive now.

This will remove the autorun.inf files from your External hard drive and also from

the drives.

Step 2:

Click on "Start" -->Run --> type cmd and click on OK.

Here I assume your External hard drive as G:

Enter this command.

attrib -h -r -s /s /d g:\*.*

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Replace the letter g with your External hard drive letter.

Now check for your files in External Drive.

Step 3:

After that, download the Malwarebytes' Anti-Malware from the below link

http://en.kioskea.net/download/download-105-malwarebytes-anti-malware

Update it --> Perform "Full Scan"

Note : Default selected option is "Quick Scan".

Good Luck.

TRUSTJACK- Jan 4, 2013 08:52PM
amazing, thank u very much, life saver...
kajapoj- Jan 6, 2013 04:02AM
I tried EVERYTHING and this is the only thing that worked. Saving ALL my travel pictures and my CV etc. THANK YOU!!!
mihirb- Jan 7, 2013 05:53AM
hey dude thankx a lot ..
Adarsh Anil Kale- Jan 8, 2013 10:38AM
Thanks dude....:) really u have saved my important files....) thank u once again....
Jacky- Jan 9, 2013 06:28AM
Thanks alot
Answer
+13
moins plus
great solution, can i delete all the shortcuts and hide system folders again?

jack4rall 6450Posts Sunday June 6, 2010Registration date ModeratorStatus April 10, 2015Last seen - Dec 2, 2010 09:33AM
Hello,
Yes, you can delete all the shortcuts or backup your data and format your pen drive and hide the system files again.
Good Luck.
phiriza- Dec 6, 2010 01:33AM
thanks a lot...
kd- May 6, 2011 02:11PM
thank you

its really helped me
Ruba- Jan 3, 2013 03:06PM
Thank You Very Much .. Very helpful ..
Answer
+10
moins plus
thank you so much for this have been able to recover important pictures from your help - bloody marvelous!!!!!!!!!

jack4rall 6450Posts Sunday June 6, 2010Registration date ModeratorStatus April 10, 2015Last seen - Oct 14, 2010 06:36AM
Hello,
Let me know what happened after entering that command. Another way is
Click on start --> run --> type control folders and press enter. Folder Options will be opened.
Click on view tab --> select the option "show hidden files and folders" and uncheck the check box
"hide protected operating system files" and click on OK.
Good Luck.
Trs- Oct 16, 2010 12:02PM
This is seriously fantastic, thanks!
GP- Oct 27, 2010 07:23AM
Thanks a bunch for the insight
mouba- May 12, 2011 08:18PM
jack4all thanks a lot it's great u saved my HD thank u
Answer
+6
moins plus
I tried the "solution" and it worked..
but now every time i plug in another external drive OR usb, it does the same thing.

how can i prevent this?

jack4rall 6450Posts Sunday June 6, 2010Registration date ModeratorStatus April 10, 2015Last seen - Jun 7, 2011 05:14AM
Hello,
Try this 1
1)Copy the text starting from "REGEDIT4" upto @="@SYS:DoesNotExist" -->
Open a "Notepad" --> Paste it --> Save the file as fix.reg
Note: Don't forget the extension "reg"
[First backup your registry. Click on Start --> Run --> Type regedt32 and press Enter.
"Registry Editor" will be opened. Click on "File --> Export"]

Now double-click on fix.reg --> Click on OK.

REGEDIT4
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]
@="@SYS:DoesNotExist"

Note : After following the above instructions, whenever you place any autoplay CD\DVD all you have to do is go to "My Computer" --> Open the CD\DVD drive ---> You have to double-click on the setup file.

2) Disable the "Autoplay" feature also.
Click on Start --> Run --> type gpedit.msc and click on OK.
Double-click on "Computer Configuration" --> Administrative Templates ---> System. Double-click on "Turn autoplay off" option and select the option "Enabled" --> Click on OK. Close that window. Now logoff and logon into your account.

3) Download the Malwarebytes' Anti-Malware from the below link
http://en.kioskea.net/download/download-105-malwarebytes-anti-malware
Update it --> Perform "Full Scan"

Good Luck
SocramZ- Jun 14, 2011 01:26PM
i did all the steps up to where you typed the "NOTE"...what kind of cd? i inserted a blank cd and it obviously popped up a screen asking to format it.
No where i saw the setup file..

so i skipped that step and tried to disable the AUTOPLAY feature, but after pressing OK..an error appeared.
jack4rall 6450Posts Sunday June 6, 2010Registration date ModeratorStatus April 10, 2015Last seen - Jun 14, 2011 02:57PM
Hello,
In "Note" I'm referring to the CD\DVD that already contains data and having the feature of autoplay(Running the setup automatically Example: Motherboard CD)
Let me know the error message and also the operating system you are using.
Good Luck
Ali- Jun 28, 2011 05:12AM
thank you so much bro, u save many imp things for me, may god bless u
nyoon- Oct 12, 2012 01:34AM
i love you!! you saved my data.. thank you.. gbu.. :)
Answer
+4
moins plus
sorry my bad I fix it thanks that s awesome.
thanks a lot for sharing

Answer
+2
moins plus
thanks a lot

Answer
+1
moins plus
thanks it helped but how do I get the transparent folders back to the original ones? Is this a stupid question to asked?

Jas- Mar 29, 2011 10:54PM
It's really working..thank you so much to "jack4rall"..God bless you...
karura- Apr 7, 2011 10:31PM
I was able to restore all of my folders to its original state. Thanks!! But what should I do with the shortcut folders? Can I erase them or do I have to archive/keep them just in case?
jack4rall 6450Posts Sunday June 6, 2010Registration date ModeratorStatus April 10, 2015Last seen - Apr 7, 2011 11:57PM
Hello karura,
After backing up your data, delete all the shorcut folders.
Good Luck
KARTHICK- Jun 19, 2011 09:46AM
thanks a lot my friend it worked and u restored my files of 218GB in just a single line thanx thanx thanx a lot my friend
jithin- Jan 6, 2013 12:17PM
thanks alot my friend
Answer
+1
moins plus
omg!!~~~ u saved my life!!!! i was able to recover all of my important files!! and the virus were removed! ur just awesome! thank you so so so so much!!!

This document entitled « Files on external drive changed to shortcuts » from Kioskea (en.kioskea.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.