Ask a question Report

Windows XP Automatic updates not working [Solved/Closed]

Yodi - Latest answer on Dec 20, 2013 02:28PM
Hello,
My computer will not allow me to turn on the windows automatic updates. Part of the issue was that I found out that I had a virus so I was able to run full scan and got rid of the virus atleast I hope so.
There is a big x over the automatic updates shield. I tried going in under control panel and turn the updates on but it will not allow me to do so. Also, I went through the security center as well but the system will not allow me to change it from off to on. Can you explain why its doing this and tell me how to fix the problem?
Thanks,
.
Read more 
Answer
+52
moins plus
1 >GO ahead and rename the "software distribution" folder to "software distribution old" on the c drive. Path is C:\WINDOWS\
2 >Once rename the folder go to Automatic updates from the control panel and disable and enable the Automatic updates.
3 >Once it is done restart the computer the Automatic updates will start download.

Good luck.

nonameatall 1Posts Monday October 21, 2013Registration date October 21, 2013Last seen - Oct 21, 2013 04:44PM
That was the move. Nice!
NickyCee 2Posts Friday October 25, 2013Registration date October 25, 2013Last seen - Oct 25, 2013 07:03PM
Arun,

I registered to this site just to thank you so very much for this solution. I spent 1.5 hours with Microsoft and another 2 hours on the web trying to fix this XP update problem. Your amazing and brilliant solution had me fixed in less than 5 minutes. Thanks you times 10 for your insight and for posting this solution!!!!
NickyCee 2Posts Friday October 25, 2013Registration date October 25, 2013Last seen - Oct 25, 2013 07:05PM
Also, you may want to add that you must boot into XP safe mode to change the folder name. Ju7st restart and hold down the F8 key. Boot into Safe mode with networking, change the name, and reboot.
Melindark- Nov 14, 2013 09:12AM
Steps I had to take:
Install IE8
Turn off Automatic Updates
Restart to Safe Mode (F8)
Rename Software Distribution to Software Distribution 2
Restart normally.
Turn on Automatic Updates
In about 10 minutes the little yellow shield appeared in the lower right corner of the screen, notifying of updates available.
(sometimes I was impatient and would check for updates online instead of waiting - was working on several at a time)
Updates did install!
bunker51 1Posts Wednesday November 27, 2013Registration date November 27, 2013Last seen - Nov 27, 2013 02:25AM
tried that could not rename file. what did work was to download and run windows update agent, I let it run for 4 hours before it succeeded getting and update past sp3, and now it works perfectly. have to be patient. i tried every other possible solution offered and none worked. i am sure you know what they are too.for what its worth this worked for me. thats my 2 cents. :-)
Answer
+6
moins plus
I was wondering if you got the problem fixed and what was your solution because I'm also having the same problem.

heather- Jan 14, 2009 12:39PM
http://www.malwarebytes.org/

I was told to update my java and run malwarebytes

Good luck!
Answer
+4
moins plus
windows is worthless!

Answer
+3
moins plus
Stop automatic update service and BITs service. Download and run http://download.windowsupdate.com/WindowsUpdate/redist/standalone/7.4.7600.226/WindowsUpdateAgent30-x86.exe

I had to reboot one machine to get it to work but the rest worked without.

Answer
+3
moins plus
You need to stop the automatic updates service. Then you can change the folder name without needing to boot into "safe mode"

Steve- Dec 14, 2013 11:10AM
Hopefully this help somebody the same way as helped me.
Install first this latest cumulative update for IE8:
http://www.microsoft.com/en-us/download/details.aspx?id=41404
for IE7:
http://www.microsoft.com/en-us/download/details.aspx?id=41442
After restart Windows automatic updates work immediatelly as well as Windows Update.
Answer
+2
moins plus
I had the same issue with being unable to rename the folder due to protection issues. The solution for me turned out to be rebooting into safe mode which then allowed me to rename the folder. While still in safe mode I turned on the automatic updates and rebooted into normal mode.

Answer
+1
moins plus
I was pulling my hair up after formatting my hard drive--and installing windows xp...then windows update wouldn't work. Tried microsoft fixit...windows update engines....finally stumbled across this site while searching the internet. And presto!! tried Arun's fix-------restarted pc and now window update works.

Thanks Arun!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Answer
+1
moins plus
thanks

for me it was enough to stop and start windows update services

Answer
+0
moins plus
Worked!! Awesome bro, thanks!!

Answer
+0
moins plus
I'm having the same problem but cannot rename the Software Distribution folder because it says it is protected. How can I overcome this? Ty.

Answer
+0
moins plus
To delete the folder "Software Distribution" do the following:

1. Browse start menu to programs>accessories
2. Right click on command prompt and run as administrator
3. Type "net stop wuauserv" (don't close out the command prompt just minimize it)
4. Browse to the windows folder and delete or rename the software distribution folder
5. Now back in the command prompt type "net start wuauserv"

Open windows update and check for updates. Should fix the problem.

Answer
+0
moins plus
thank you Arun!

This document entitled « Windows XP Automatic updates not working » from Kioskea (en.kioskea.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.