Kioskea
Recherche
Ask a question Report

Cannot access shared folders remotely [Solved]

maqs - Latest answer on Aug 16, 2010 04:45AM
Hello,
I have a shared folder (e.g. MyFolder) on a Win XP SP2 computer (e.g. MyPC) with share permission for 'Everyone' having full control and security permission for 'Users' and 'Administrator' of the computer (MyPC).
When I try to access the shared (MyFolder) from another computer I get the following message
\\MyPC\\MyFolder is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
Access denied
I wonder why I am not getting the login prompt for user name and password ???
When I type \\MyPC\c$ I get a the login prompt. but when I type \\MyPC\MyFolder I get the above mentioned error.
Please help.
Thanks and regards
maqs
Read more 
Answer
+86
moins plus
<gras>Dear sir/madame
In my Lan office on windows XP2 i shared a folder and error is that (my Folder is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. ..). How to solve this error please reply thanks.
Add comment
Answer
+33
moins plus
The $ sign states that's it's an administrative share, and gives you access to the root of the drive. You cannot access the folder without the $. Unless you want to permit everyone access.
ghost42- Jul 12, 2009 03:04AM
Uhm... no. The dollar sign ($) at the end of a windows share designates that it is "hidden", it does NOT mean that it is administrative. All of the default administrative shares have $ at the end (\\<mycomputer\c$ etc) because they are created automatically, and they microsoft wanted them to be hidden.

You can add a $ to the end of any share name and it will not show up in any browse window. IT managers use this trick all the time to create shared folders that they don't want to show up in normal searches, but still be shared if the user and/or system knows how to get to it.
Reply
Add comment
Answer
+16
moins plus
First ensure there is no firewall blocking (Antivirus firewall, Windows firewall, etc) on computers, after that have a look on these simple file sharing or share file with user/group permission in XP articles, maybe you did not configure file sharing correctly.
Add comment
Answer
+14
moins plus
An easy way to get around the issue of an XP client not promting for username and password when accessing a shared folder is to map the shared folder as a network drive. On the client machine (XP), you can create a batch file to run anytime you need to connect the folder. create a text file with these contents: net use J: "\\pathname\to\share" password /user:your_usere_name. save it as a .cmd file. you can also run the command prompt of course. on some routers especially if its crossing from wired LAN to wireless the friendly names don't map through. so you might have to use the ip address of the sharing computer instead of its name.
Hal_Ber- Mar 27, 2010 01:08PM
You do not necessarily need to map it as network drive:
NET USE "\\ComputerName\Share" /user:Domain\UserName (better not to put the password in clear).
If you are not prompted for a password when you access a share most probably:
1) There are credentials already cached for that resource (check on "User Accounts / Manage your Passwords")
2) There is already a connection remembered for that resource (you can list all of them with "NET USE" and then use the /DELETE switch to remove it.
Reply
Add comment
Answer
+12
moins plus
hey Meck@STL,

"The tweak is there, to click on 'don't require passwords' in that Win7 tool. "

is there a same tweak on windows xp computers? both my xp pro and xp home dun prompt for passwords when i connect to the folder on my server(xp pro with permissions for specific users set)

currently i can use my Macbook to select "Connect As" when i select the folder and enter the authentication. but the windows computers just prompt "Access Denied"

Thanks for all your support guys.

Cheers!
Evan
Add comment
Answer
+8
moins plus
Fix my issues:

The account on the computer i wanted to access had the the option user must change password on next logon(
control pannel / administration tools / local user and groups / user / select user )

Uncheck and check password never expire

Then it work.... i guess because i never went into the account, i never notice the password change
Add comment
Answer
+6
moins plus
If you have enabled folder sharing with user/groups permission on computerA and allow user Alice to access, Alice must log on to Windows XP by using username Alice and Alice’s password on computerB when she tries to access this computerA's folder from computerB.
Add comment
Answer
+5
moins plus
spazzy,

you are aware that this will also give access to anonymous users? probably not a good idea, especially at a company
Add comment
Answer
+5
moins plus
Hi

Check the permission both in security and sharing option.In both option, permission must be given to everyone.
Add comment
Answer
+4
moins plus
I read over all this and other sites and have finally fixed this problem. Its not the firewall. Its not the homegroup. Its not anything on your XP machine. And its certainly not all those people that ask for your Service Pack level and amount of memory.

Get to the Network and Sharing Center / Change Homegroup options / Change Advanced Settings

You should be on a "home network" if you are behind a your cable/dsl router and sharing with other PCs in the home.

You will need to turn off passwords for your home network, if you normally don't use them. If you want passwords, you'll set them in the share diag (see next para).

You will need to click on a folder from windows explorer and chose properties, then sharing, then advanced. I found my 'users' folder and everthing in it is shared by default. I turned off sharing on that folder and used one at a lower level and share it to 'everyone'.

Finally, here's what will make XP network with 7. You need to go to your adapter (wireless or wired). From Network and Sharing Center, click on 'Change adapter Settings' on the left margin. Next, right-click and choose properties for the adapter you use. Click the sharing tab at the top, and then select the check box starting with "Allow other network users..". I also deselected the second box. The second one if for someone like IBM or HP to remotely access your PC for troubleshooting.
Add comment
Answer
+3
moins plus
1. Share folder (XP, VISTA, 7)
Make a new folder or use an existing one, anywhere. Right click this folder and choose properties > sharing. Do the thing. You might have to turn off simple file sharing (XP).

2. Set permissions (XP, VISTA, 7).
Right click shared folder > properties > security. Add the user who you want to have access (if you don't care, add 'everyone' with full permission).

If you want to permit only specified users aka not 'everyone' then you might have to add those user as local users accounts on the computer you'r shareing a folder (XP). These accounts might need a password (depends on your share settings).

If you add new accounts to the sharing computer you might want to hide these from the XP Welcome Screen. Check these instructions for that: http://www.intelliadmin.com/...

If this does not help: go to http://www.google.com (or your preferred search engine) and type in "sharing folders in windows XP" or any error message you'r facing.
Add comment
Answer
+2
moins plus
hey Meck@STL, i cant seem to find network and sharing centre... are you advising for windows xp fix?

is there something on the client or server that i can tweat such that windows will prompt me to authenticate instead of showing me access denied and no other manner to log on to the folder?

Cheers!
Evan
Meck@STL- Jan 8, 2010 10:39AM
no, I understood the problem to be this;
Win7 can see/manipulate XP files via share, but XP cannot see files/login to Win7.

the Network Shares Center mentioned is new for Win7, not in Vista or XP

The tweak is there, to click on 'don't require passwords' in that Win7 tool.

If you have XP to XP, then passwords are set when you create a user account. XP Pro/Home handle authentication differently, but I have both types machines on my network and they all share just fine.

If you don't have the advanced sharing menus in XP, you need to disable simple file sharing. From a folder window, click tools, folder optiosn, view, scroll to bottom and deselect "use simple file sharing".
Reply
Add comment
Answer
+2
moins plus
Evan- Jan 20, 2010 12:05AM
Thanks RK, but do you know of any tweak for windows xp home and pro?
Reply
Add comment
Answer
+1
moins plus
Hi guys,

Great info here but i'm still having a similar problem. My files are stored on a XP pro sp3,
- i've removed 'simple file share'
- created 3 user profiles
- set premissions on the folder for different users
- shared the folder in the network

I am able to access the folders using my macbook as i can choose to "connect as" (input the user and pwd created earlier) then open the folder

BUT

i am unable to access the folders with my other windows xp sp3 (mix of home and professional) computers (client computers). when i select the folder it prompts :

"You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. "

How can i get the client computers to prompt for a username and pwd when i try to access the computer through the network?

Please help! i am going insane with this one problem and i have been googling and trial testing a lot already....

Cheers!
Evan
Hal_Ber- Mar 27, 2010 01:17PM
See my comment above.
Try to do everything from Dos Prompt; you have more control and specific commands. I can promise you that as soon as you get used to it you can easily troubleshoot any of these issues..
Also never forget to specify the user in full (e.g. LAPTOP001\pippo) where laptop001 is the pc where you created the account that has permission on the folder.
Reply
Add comment
Answer
+1
moins plus
i hope that i did not get any answer for question
Add comment
Answer
+1
moins plus
Try turning off the Windows Firewall
Add comment
Answer
+0
moins plus
how can problem solved, pls help me!
Add comment
Answer
-1
moins plus
Just have a look at the security. Add Everyone and give "everyone" full access. Everyone should be in the share as well as the security.

That's how I always solve the problem at work.
Pic- Apr 19, 2010 10:11PM
You should NEVER do this unless it is a fully public share!!
Reply
Derek- Jun 10, 2010 10:18AM
You can add everyone to the share permissions and then let NT Permissions take care of the security, but should not add everyone to both....adding everyone to the NT security permissions allows exactly everyone to access the share...not very secure if you want it to be
Reply
Add comment
Answer
-1
moins plus
Thanks for that solution Roandr.

It worked like a dream for me.

Just one additional thing,

It is not enough just to add the user account on windows XP you have to be logged into the account itself to actually access the folder restricted to that user on the other machine.

Example: I restricted a shared folder on my Windows 7 machine to a user called network_guest.

I have to be logged in as network_guest with the right password on windows XP to access said folder.
Hal_Ber- Mar 27, 2010 01:26PM
Not necessarily. XP can cache any credentials on your current account. The credential is mapped to the server name. So if I log in as Hal_Ber I can still authenticate as pippo for a specific server as long as I cached that credential.
Check in the control panel / user account / Manage my passwords (or similar).
Reply
Add comment
Answer
-1
moins plus
You can see sharing folder. If you have cannect the network so first up all you con go to the control pannel and double click Netwark and setup wizard configure to the workgroup after finnish and resolved your problem.
Add comment
1 2 Next
This document entitled « Cannot access shared folders remotely » from Kioskea (en.kioskea.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.