Ask a question Report

My fn key not working [Solved/Closed]

sachin - Latest answer on May 5, 2015 10:44AM
Hello,
I formatted my vaio laptop. After formatting its fn key not working.
Please help me
regards
sachin Tiwari
Read more 
Answer
+464
moins plus
In your 'Start' menu click on 'Run' and type in services.msc
You'll see a long list called Services (Local), click on the name parameter to have them sorted alphabetically.
Find the one called VAIO Event Service. Double click this and ensure that for Startup Type it says 'automatic', if it does not, change it to 'automatic' and click 'apply'.
Then be sure below that, that the Service Status says 'Started'.

This should help, I had the same problem where I could not use my Fn key to adjust volume or brightness and this solution worked for me. Bonne Chance!

mw- Aug 5, 2010 03:03AM
Awesome!!! Spot on with that. I'd seen answers about downloading drivers...yadda, yadda, yadda. This was quick and easy. Beautiful!!! Muchas Gracias!!!!
John- Aug 6, 2010 08:57PM
there nothing say "vaio event services' in my laptop! please give further advise thanks a lot
dre7am- Aug 23, 2010 10:45PM
it works but not with the brightness and the zoom functions
Darragh- Aug 28, 2010 10:37AM
I don't know who you are, but your suggestion worked for me as well. Thank you so much.
Hazelino- Oct 10, 2012 07:18AM
I have the same problem (sound and brightness are suddenly no longer adjustable) but i have a ASUS though, will this help me too? What do i have to look for when going through the services list?
Reply
Answer
+28
moins plus
In your 'Start' menu click on 'Run' and type in services.msc
You'll see a long list called Services (Local), click on the name parameter to have them sorted alphabetically.
Find the one called VAIO Event Service. Double click this and ensure that for Startup Type it says 'automatic', if it does not, change it to 'automatic' and click 'apply'.
Then be sure below that, that the Service Status says 'Started'.

Answer
+25
moins plus
When you format a viao machine it doesnt always put the Fn controls back the original way. The drivers will be there just not activated on Startup. So you have to enter the msconfig, go to startup and turn on the Hotkeys, depending on the system there can be a number of driver devices which you need to make sure are started up. If your not sure then turn on all the startup programs and reboot. You should then have the Fn controls back. However you may also have about 40 processes running that you don't need. So turn off those that don't appear to be hotkey controls. You may need to play around with turning some off and reboot for a while.

Answer
+19
moins plus
Hello,
you should try going onto the manufacturers website and finding your laptop model.
they might have a driver for your keyboard.

Answer
+18
moins plus
I think I've solved the problem. I recently installed win7 ultimate x86 (32 bit). It was a clean install and I had no backup of any drivers whatsoever since I was switching to windows from linux. My vaio model is sz2hp/b.

After installing win7 didn't see the GeForce card so I manually installed nVidia driver and then Sony Event services, Sony Shared Library respectively from http://support.vaio.sony.eu/...

Windows 7 itself pointed out that there was a missing driver which was "Sony Programmable I/O Control Device (SPIC)". I googled it and decided to install the closest driver I could find which was not really compatible with Win7 but after a few attempts of installing the same driver the problem was somehow solved.

Some of the remaining hardware drivers such as the webcam and memory stick reader was found by win7 troubleshooter. I'm surprised how good the win7 troubleshooter works!

Thus far everything was working except the fn key shortcuts.

Lastly I went to the same vaio support page and I installed Sony Utils DLL. After installing this last item my Fn keys started to work after a reboot!

Note: All drivers I downloaded from Sony Support site are Vista drivers. I realized that win7 is very compatible with vista drivers, even some XP drivers can solve many problematic hardware.

Answer
+17
moins plus
thank you so much!

Answer
+4
moins plus
sony users....
1.Click the Start button, then click Run .
2.In the Run window, next to Open , type MSCONFIG .
3.Press the ENTER key.
4.In the System Configuration Utility window, click the Startup tab.
5.On the Startup tab, under Startup Item , ensure that there is a check in the HKserv checkbox.

NOTE: If HKserv is missing, reinstall the HotKey Utility application and the Sony Utilities Library.


Click the OK button.
In the System Configuration box, click the restart button.


IMPORTANT-

reinstall the HotKey Utility application and the Sony Utilities Library.
reinstall the HotKey Utility application and the Sony Utilities Library.
vyas- Dec 12, 2014 07:36AM
its working thanks....
i m finding solution for same from past few months
once again thanks
Reply
RickDahari- Dec 15, 2014 04:35AM
Thanks Justhelp. Mine works after following your recommedations.
Reply
goody- Jan 22, 2015 10:43AM
there is no VAIO service in my list
plz do help
Reply
Rivka- Mar 10, 2015 06:01AM
I'm in love/bookmarked your page....IT WORKED!!! After 45 minutes with an almost-incomprehensible SONY/VAIO 'Help' person, I just hung up and started searching on the web. There you were and answered my dilemma. THANKS.
Rivka
Reply
Naved from Dubai- May 5, 2015 10:44AM
Awesome man....i was about to format my entire HDD, but came thru you page and its working fine...Thanx again and keep the good working going.
Reply
Add comment
This document entitled « My fn key not working » from Kioskea (en.kioskea.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.