Ask a question Report

All drives are not open by double click & win [Solved/Closed]

raj - Latest answer on Apr 3, 2014 11:04PM
Hello,
My PC having four drive & it is not opening with double click & showing open with programm,even same error is showing when opening with explore.OS is XP.
Regards
Rajesh
Read more 
Answer
+50
moins plus
Virus trouble

Sometimes it happens in windows XP that you are not able to open drives on your hard disk. When you double click on the drives icons or right click on the drive>>explore in My computer ,the drive does not open.

This problem is generally caused by most of the viruses which infect windows XP system. They block or restrict your access to any of the drives.

But don't worry this is not a big trouble it can be fixed easily.

Fix:

Normally when a virus infects a windows system which causes a drive opening problem, it automatically creates a file named autorun.inf in the root directory of each drive.

This autorun.inf file is a read only ,hidden and a system file and the folder option is also disabled by the virus. This is deliberately done by the virus in order to protect itself. autorun.inf initiates all the activities that the virus performs when you try to open any drive.

You have to just delete this file and restart your system to correct this problem.

Follow the set of commands below to show and delete the autorun.inf

1. Open Start>>Run and type cmd and press enter. This will open a command prompt window. On this command prompt window type the following steps.

2. type cd\

3. type attrib -r -h -s autorun.inf

4. type del autorun.inf

5. now type d: and press enter for d: drive partition. Now repeat steps 3 and 4. Similarly repeat step 5 for all your hard disk partition.

Restart your system and your trouble will be fixed.

saini- Feb 1, 2014 12:24PM
thnku sir
ahmed- Feb 5, 2014 11:30AM
Great . Thank you
praval- Feb 28, 2014 10:28PM
Thanks, My drives didn't open by double clicking,however opened with -run-explorer drive: you saved the day thanks again mate
pandu- Mar 10, 2014 11:45PM
Thank you very much . Issue is resolved in my PC. :-)
raha- Mar 12, 2014 01:16PM
when i open my drives, show me a msg "restriction with administrator" whereas i'm in an administrator's drive...!
plz send me an answer :(
Answer
+12
moins plus
Very simple . virus create some bad registry if you want to solve this problem then delet this registry


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2


delete all drive from here

Jony- Apr 19, 2010 04:22AM
I want to thank you for this superb read!! I certainly enjoyed every little bit of it.
I have bookmarked your site to check out the latest stuff you post.
http://www.oaktree.com.au
Steve- Apr 20, 2010 04:29AM
I want to thank you for this superb read!! I certainly enjoyed every little bit of it.
I have bookmarked your site to check out the latest stuff you post.
http://www.electricians4u.com
rock- Feb 11, 2014 10:13AM
thanks you sooooooooooooo muchhhhhhhhhhhhhhhhh
dinesh kumar- Mar 13, 2014 12:57AM
thanks problemssolved my
PaSTie- Apr 3, 2014 11:04PM
ty ty ty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Answer
+9
moins plus
Hello,
My PC having four drive & it is not opening with double click & showing open with programm,even same error is showing when opening with explore.OS is XP.

Answer
+5
moins plus
Hi,
Super. nice trick. thank you

zaq- Jan 23, 2009 05:15PM
hi buddy thanx very-very -very much its working 100% without any problem. it save my importnat data to open
thanx once again itz a very good fix. awesome.thanx
pankaj- Feb 14, 2014 10:45AM
still not working .... please provide me a better opinion about this severe problem which i am facing....
Answer
+4
moins plus
sir ur a genius thanks

MikeBelly- May 19, 2010 11:55PM
Thanks a lot sir, it worked.
Mike Belly
http://losebellyfat101.org
Answer
+4
moins plus
Hi everyone, I have the same problem when I open My Computer then double click one of my drives (c or d) it opens up an image program (ACDseePro) instead of expolring it, I have to right-click then open or explore.
I have tried the command prompt ( autorun.info) but file was not found in any of the drives , I also tried gpedit.msc and enabled autoplay but it didn't work. Used Spybot serach&destroy, Flash-Disinfect, Disc-Heal, Fix-Drive and did a virus scan with NOD32 but nothing was found and the problem still persists!!!!!!!!!!!!!

Please advice

Answer
+2
moins plus
Thanks for the info and solution that you have shared...
keep it up, more power and knowledge...

Answer
+2
moins plus
Thanks it work fixall ,all others mention in this replies, didnt work for me.

Answer
+2
moins plus
Thankyou boss my problem is now resolve

Answer
+1
moins plus
thanks it worked for me! ^^

Insurancemaster- Apr 29, 2010 07:29AM
this is something that I should have found a couple of months ago.anyways thank for such a wonderful post.
What a great article.. complete with the + and - . Yup.. it's very useful. Thanks
http://www.myinsurancemaster.com
Answer
+1
moins plus
thanks allot

Answer
+1
moins plus
Thank you so much for guide me

Answer
+1
moins plus
Thanks alot Pal from all the way in Jamaica! Jah Guide...

Answer
+1
moins plus
I m unable to open my drives with double click on it nd its giving the msg open with.....
i tried the autorun delete option also but i typed attrib-r-h-s autorun.inf but it is not reconizing it . heilp me

Answer
+1
moins plus
regsvr32 /i shell32.dll
OR
HKEY_CLASSES_ROOT\Directory\shell none

Answer
+0
moins plus
Dear Sir
i tried your solution and it worked and i just want to thank you........
thank you very very much and God Bless U...................................

Answer
+0
moins plus
I have a simuliar problem, but can't type the command attrib -r-h-s autorun.inf ..my computer doesn't recogize it, I tried various other ways in format it, no luck. I have windows xop any ideas?

musheer- Mar 21, 2010 05:16AM
after typing -r give one space then repeat the same for -h and -s , mean give one space between all
Answer
+0
moins plus
First you type cmd and enter

Then type

attrib -r -h -s autorun.inf without a space between the minus sign and the following letter but a space before the minus sign - this makes the file visible and allows you to delete it later. If DOS returns "file not found" it means the autorun.inf file is not on that hard disk.

M@veriCk- Jan 27, 2009 11:00AM
Thanx dude....
abhijeet Frozen - Nov 23, 2009 08:39AM
dude u r great it solve my problem too
Yesh- Feb 1, 2009 10:09PM
Thanx dude........
this trick has solved my problem.
vijay- Apr 18, 2010 09:50AM
thank u very much.........
SunSine- Apr 19, 2010 04:26AM
Many Many thanks dear for posting this useful information....
http://www.removalists4u.com.au
Answer
+0
moins plus
hard disk drive is not open

muke- Feb 1, 2009 09:43PM
Virus trouble

Sometimes it happens in windows XP that you are not able to open drives on your hard disk. When you double click on the drives icons or right click on the drive>>explore in My computer ,the drive does not open.

This problem is generally caused by most of the viruses which infect windows XP system. They block or restrict your access to any of the drives.

But don't worry this is not a big trouble it can be fixed easily.

Fix:

Normally when a virus infects a windows system which causes a drive opening problem, it automatically creates a file named autorun.inf in the root directory of each drive.

This autorun.inf file is a read only ,hidden and a system file and the folder option is also disabled by the virus. This is deliberately done by the virus in order to protect itself. autorun.inf initiates all the activities that the virus performs when you try to open any drive.

You have to just delete this file and restart your system to correct this problem.

Follow the set of commands below to show and delete the autorun.inf

1. Open Start>>Run and type cmd and press enter. This will open a command prompt window. On this command prompt window type the following steps.

2. type cd\

3. type attrib -r -h -s autorun.inf

4. type del autorun.inf

5. now type d: and press enter for d: drive partition. Now repeat steps 3 and 4. Similarly repeat step 5 for all your hard disk partition.

Restart your system and your trouble will be fixed.
rgm- Feb 12, 2009 07:37PM
I use win xp pro. I had an autorun virus which blocked opening of the drives. I ran the program flash disinfector and the virus problem was solved. but from my dvd drives, no cd/dvd starts on its own unless click the dvd-drive icon. how can i get back the 'autorun'? i changed shell detection using gpedit.msc, enabled autorun from properties..nothing works. Can anybody help?
nagraj muke - Feb 21, 2009 11:29PM
hai this is nag. iam suffering from this problem since a month. n finally solved my problem. thanx a lot yar.
Answer
+0
moins plus
PERFECT SOLUTION It magically worked for me

Pradyot

1 2 Next
This document entitled « All drives are not open by double click & win » from Kioskea (en.kioskea.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.